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Processing LiDAR data to extract hydraulic radii of the Colorado River downstream of Max
Starcke Dam, near Marble Falls, TX

I. Problem Formulation

Part of my dissertation research is focused on boulder transport. Downstream of
Max Starcke Dam (Figure 1) I have attained access to a coarse boulder and gravel bar on
the north side of the channel. I will be installing time-lapse stereo cameras to take hourly
images of the bar from an elevated carbonate bluff. Water released from Max Starcke Dam
is often sudden and intense, which means for a large portion of the time the bar is sub-
aerial, but during dam releases, the bar is rapidly submerged and presumably, boulders are
transported. My goal for this portion of my dissertation research is to use the stereo
images to quantify boulder transport, which I will be able to identify and quantify using
specialized software that can construct topographic surfaces from stereo photos. The
difficulty of this project is that the dam is ungaged, so I have no discharge data to calculate
flow velocities, and therefore, am unable to link boulder transport to flow characteristics.
The purpose of this project (as it pertains to this course) is to use elevation data collected
via airborne LiDAR (light detection and ranging) to calculate hydraulic radii at several
cross-sections along this reach of the Colorado River. From these cross sections, I will be
able to use water elevation data captured in the time-laps imagery to calculate a water
surface slope, from which I can calculate velocity using the Manning equation:

U =R2/3S1/2n—] (1)

where U is mean velocity (m/s), R is hydraulic radius (m), S is slope (m/m) and n is the
Manning’s roughness coefficient (0.035 for this channel). For the sake of this project I will
be calculating hydraulic radii, and using n=0.035 to calculate a range of slope-dependent
velocities

II. Data Collection

[ downloaded the LiDAR data from a CAPCOG (Capital Area Council of Governments)
public workstation at 6800 Burleson Road, Building 310, Suite 165, Austin, TX 787544.
This data comes as a .las file. In the .las form the files cannot be directly imported into
ArcGIS or viewed in a text editor program due to their size. A major problem I encountered
with this data is that projection information is (supposedly) described in the header of the
Jas file, but being unable to read the file prior to converting it to another format, I had
problems getting the proper projection (more on this in a moment). I also downloaded
additional data from the CAPCOG information clearinghouse
(http://www.capcog.org/information-clearinghouse/geospatial-data/) specifically,
hydrography data to identify thalweg location and 6 inch resolution orthoimagery from




2009. The latter two files included full metadata, with projection in NAD 1983 Central
Texas State Plane (feet). A problem arose projecting the LiDAR data due to misinformation
on the CAPCOG website. On the website they state that LiDAR data are projected in UTM
Zone 14 (meters), but upon projecting the data in this way, it placed the data near the north
pole. After several hours of head scratching we (Dr. Helper and I) identified that the LiDAR
data needed to be projected in NAD 1983 Central Texas State Plane (feet). This solved the
problem. I downloaded LiDAR from the Marble Falls and Smithwick Quad, which was shot
with 1.4m (4.59 ft) resolution.

[II. Data Preprocessing

The only preprocessing I completed was converting the .las file to a feature file. To
do this I used the ‘LAS to Multipoint’ toolbox (3D Analyst>From File>LAS to Multipoint). To
use this feature (Figure 2) I identified the .las files to be converted, the location of the
multipoint feature to be created, the point spacing (resolution) and the input class code,
which refers to the LiDAR return value (2 is the “bare earth” return). I did not input
projection information; for reasons I do not understand, whenever I tried this step with
projection information it did not work. After importing the file I used the ‘Define
Projection’ (Data Management>Projections and Transformations>Define Projection)
toolbox to project the feature in the NAD 1983 Central Texas State Plane (feet) projection
(Figure 3).

IV. ArcGIS Processing

Once the Multipoint Feature was in ArcGIS I wanted to create both a TIN
(Triangulate Irregular Network) image followed by DEM (Digital Elevation Model) raster. |
constructed the TIN in order to link the individual points together in a continuous fashion
(i.e. a surface), and from this TIN I created a DEM. There were some regions of the
Multipoint Feature that were missing, I initially attempted an Inverse Distance Weighted
(IDW) interpolation technique, but the results did not significantly improve the area I am
interested in, so I did not complete this step in my final analysis. Finally, I used the 3D
analyst function to construct 12 cross sections downstream of the dam.

Steps for analysis:

1. Create Polygon shapefile—using ArcCatalog, I created a new shapefile to construct a
polygon that I would use to clip the Multipoint Feature (and orthophotographs) to
the dimensions [ needed. The quads I used cover a much larger area than I needed
for my analysis (Figure 4).

2. Create TIN—3D Analyst>TIN Creation>Create TIN—allowed me to create an empty
TIN file and define the projection (Figure 5).

3. Edit TIN—3D Analyst> TIN Creation>Edit TIN—allowed me to import the clipped
Multipoint Feature into the TIN (Figure 6).

4. TIN to Raster—3D Analyst>Conversion>From TIN>TIN to Raster—used vertices
(and corresponding elevations) from the TIN to create a Raster (Figure 7).

5. Create Hillshade—Spatial Analyst toolbar>Surface Analysis>Hillshade—I created a
hillshade from the raster for both map-making purposes (adds depth to the DEM)
and it is easier to visualize changes in topography (Figure 8).



6. Add CAPCOG hydrography shapefile and clip—I added the CAPCOG hydrography
shapefile using the ‘Add Data’ icon, then using Analysis Tools>Extract>Clip, I clipped
the hydrography shapefile using the clip_box shapefile I created in step 1 (Figure 9).

7. Use Interpolate Line icon to construct cross sections—I used the ‘Interpolate Line’
and ‘Create Profile Graph’ feature on the 3D Analyst toolbar to construct a series of
cross sections running from just below the dam to the pool at the end of the study
reach (Figure 10). I then clicked on each plot individually, right-clicked, clicked on
the ‘Data’ tab, and saved the cross section in the Excel format. Using the same
method outlined in step 1, I created a shapefile to construct lines that shadow the
cross sections so [ would have a record of where the cross sections were measured.

8. Calculate hydraulic radius for cross sections—for this portion of the analysis I only
calculated the hydraulic radius for cross section number 5 and 10 because this is
where [ will have cameras installed. Additionally, I only calculated the hydraulic
radius up to 5m above the lowest point on the bed, as field evidence suggest flows
do not exceed this depth.

9. Calculate flow velocity—Using Equation 1, the results from step 8, and a range of
slopes I calculated mean flow velocity at the two cross sections.

V. Results

[ calculated the mean velocity at two cross-sections (Figure 11) using Equation 1. I
quantified the cross sectional area and wetted perimeter in depth increments of 0.5 m
(Table 1). The result of this analysis is a type of rating curve (Figure 12), where, for a given
depth and slope I can predict the mean velocity. I will be the first to admit that this analysis
contains many sources of uncertainty, but as a first step in understanding the flow
dynamics in this region, [ believe this will be sufficient. One way to test this rating curve is
measure the base flow velocity and find where it would plot on the rating curve. When I
visit the site in mid May I will be doing this. Based on the results of the rating curves for
both cross-sections, I hypothesize that the water-surface slope (S) will be 0(0.01), as this
produces velocities around 1-4 m/s, which seem most realistic. I cannot base these
calculations on bedslope (which could be easily calculated in ArcGIS) because Lake Travis,
which is immediately downstream, will exert a large influence on local base level and these
level tend to fluctuate often. For the sake of demonstrating the rating curve I have plotted
two different rating curves (for each cross section), each showing velocity as it corresponds
to slopes ranging from $=0.1—0.00001. In reality, the slope will be calculated from
differences in water surface elevations that I detect in the time-lapse images between the
two sites.

VI. Conclusion

Based on the analysis performed through this research project it is evident that
there is great potential to use LiDAR to calculate channel geometry. This project was
limited by my understanding and capabilities using ArcGIS. Specifically, I calculated the
cross-sectional area and wetted perimeter in excel, which is both time consuming and not
the most accurate. [ am sure there is an alternative method that I could have employed that
is not only more accurate, but faster. Matlab would be a very good program to use for this



sort of analysis, which I know can be used very efficiently in conjunction with ArcGIS. As
my skills in both programs progress I hope to reanalyze the data and recalculate the rating
curves. I also believe it would be very beneficial to exhaust every resource I can find that
may shed light on discharge values for this site, either from upstream/downstream gaging
stations, lake levels, or some other method. Finally, one large uncertainty that cannot be
avoided with this type of analysis is the effect of water on the laser return. There are
certain areas (especially upstream of Max Starcke Dam) that have clearly been affected by
poor returns. Fortunately, in the area I'm studying this is minimal. Finally, because water
appears as a bare-earth surface to LiDAR there is a possibility that 'm not seeing the
channel bed but the water surface. I believe this affect to be minimal because data was
collected when the reach was at extremely low flow.



VII. Tables
Cross-Section 5

Depth (m) Cross-Sectional Area (m?)

Approximate Wetted-
Perimeter (m)

Hydraulic Radius (m)

0.0 0

0.5 22
1.0 57
1.5 108
2.0 170
2.5 233
3.0 300
3.5 374
4.0 451
4.5 532
5.0 614

0
108
158
212
224
242
260
284
314
328
336

0
0.20
0.36
0.51
0.76
0.96
1.16
1.32
1.44
1.62
1.83

Cross-Section 10

Depth (m) Cross-Sectional Area (m?)

Approximate Wetted-
Perimeter (m)

Hydraulic Radius (m)

0.0 0]

0.5 20
1.0 52
1.5 86
2.0 122
2.5 162
3.0 211
3.5 264
4.0 320
4.5 380
5.0 441

0
112
132
144
152
168
204
208
228
248
268

0.00
0.18
0.39
0.60
0.80
0.96
1.03
1.27
1.41
1.53
1.65

Table 1. Channel geometry at cross section 5 and 10

[ calculated the hydraulic radius by measuring the cross sectional area and wetted
perimeter in 0.5 m increments. Note: hydraulic radius, R=A/P, where A is the cross

sectional area and P is the wetted perimeter.



VIIIL. Figures (ArcGIS Screen Captures)

Figure 1. Location of study site relative to Marble Falls, TX.



Figure 2. LAS to Multipoint toolbox and resulting data.

[ used this toolbox to convert the raw LiDAR data into a multipoint feature that could be
imported and viewed in ArcGIS. The resulting data is so dense that features are virtually
indistinguishable. Note: In order to NOT create an artifact (seam) between my two quads,
[ processed both quads together (Marble_Falls_SEB and Smithwick_SWA).



Figure 3. ‘Define Projection’ toolbox
[ used this toolbox to define the projection of the converted .1as file.

Figure 4. Create a shapefile to clip the Multipoint Feature

After creating the shapefile in ArcCatalog using the above dialog box [ added the shapefile
to ArcGIS. I then used the editor toolbar to construct a polygon that enclosed the area of
the two quads that were pertinent to my analysis. Here is an image of the Clip_Box
superimposed on a portion of a previous raster.



Figure 5. Create TIN dialog box
[ used this tool to create an empty TIN with the correct spatial reference.



Figure 6. Edit TIN dialog box and resulting TIN

[ used this tool to populate the TIN with the multipoint feature data. Part of the .las file
conversion creates an attribute table with the field called ‘shape.” This field corresponds to
the elevation of each feature, thus it is the field I call upon in the ‘height_field’ column in the
above dialog. Looking at the TIN image it is evident where Max Starcke Dam is by the
sudden change in elevation and emergent bar features that are not visible upstream of the
dam.



Figure 7. Creating a raster from a TIN and corresponding result

[ used the TIN to Raster toolbox to complete the conversion. I used the default options for
the Output Data Type and Method but changed the Sampling Distance to 4.59 to
correspond to the resolution of the LiDAR and I used a Z Factor of 0.3084 to convert the
elevation from feet to meters.



Figure 8. Creating a hillshade layer

[ created a hillshade raster layer from the Raster I created in the previous step. As in
previous steps I used the default options and chose a folder for the output raster to save
too. The above image is a screen shot of the hillshade produced in this step with the raster
produced in the previous step draped over.



Figure 9. Add clipped hydrography shapefile

[ added the hydrography shapefile to ArcGIS, and then using the above dialog box, I clipped
the file to only contain channels within my immediate study area. The above screen
capture shows the clipped hydrography overlain on the raster and hillshade layers.



Figure 10. Location of 12 cross sections and one example

The above screen capture depicts the location of the twelve cross sections as well as the
DEM and the clipped hydrography layer. The second screen capture depicts example cross
sections 5 (left) and 10 (right). Note: horizontal units are in feet and vertical units are in
meters.
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Figure 11. Reconstructed cross sections

These cross sections are taken from data at sites 5 and 10. I reconstructed the cross
sections from the data exported from ArcGIS so they only include the area I am interested
in (lowest point on the bed and up to 5 meters above it).



Depth-dependent velocity at cross-section 5
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Depth-dependent velocity at cross-section 10
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Figure 12. Mean velocity rating curve

[ calculated the rating curve using Equation 1. I was able to directly measure the hydraulic
radius at each depth and then calculated the mean velocity at that depth for a range of
slopes.



